Easypark-linear-logotype_RGB
easypark image

EasyPark
service status

Stay up to date on availability of our services.

Service Incident: March Clearing Reports delayed

Incident Report for EasyPark

Resolved

The incident has been resolved.

The following operational disruptions occurred:

- Clearing Reports

All impacted services are available and closely monitored. Actions are taken to (re)process data that may have been impacted by the incident.
Posted Apr 02, 2026 - 11:39 CEST

Identified

We are currently experiencing the following operational disruptions:

- Clearing Reports (March)

The cause of this incident has been identified. We are working on a solution to resolve this soon.

Next update will be shared when the status of this incident changes.
Posted Apr 01, 2026 - 10:17 CEST
This incident affected: Clearing reports.